Miner disconnects/dropping of network

Hello All,

I’ve got 2x mining rigs (Ryzen 9’s). 1 has been running since late August and the other one for a month.

1 of them for whatever reason (the older one), the I.P address drops off the network. Once i realise this has happened (hash drops significantly from 20-24,000 KH/s to 10-11,000 per hour. I then have to reset the rig every time this happens. It’s happen 4 or 5 times now in the last month and I don’t know why.

Any idea as to why this occurs?

1 Like

Tried a different Cat cable?

1 Like

Yes, swapped the cable with my rig that’s running with no issues. Didn’t fix the problem.

1 Like

This looks like the same issue i am facing. Your network card suddenly drops.

There is 2 options:

  1. Keep on rebooting it when it happens until it doesn’t run anymore
  2. When option 1 dont work. Reinstall the whole Safex OS

Thanks, will try installing again if it continues to happen.

1 Like

There are a few bugs that can crop up, and usually it is connected with home network set up.

We have been testing a new iteration of the SFXOS, but i’m not sure when we will release it.

Just as an example, my router is fairly too weak to manage with a farm of 80 machines, I will be buying better hardware for the network to see how we can affect the software to detect problematic situations and mitigate them.

Only trying and seeing issues will show us how to make the software more perfect. Yet so far so good. Do let us know how it goes further


Not having much luck, it’s gone offline again.

I did reinstall SFXOS and change Cat cable again but no luck. I’ll just keep resetting it for now. I only just brought the router a few months ago when i started mining, i might buy another one at some point or just deal with it until a new iteration is released.

I’m not overly worried about it, just inconvenient.

1 Like

yep. i am facing the same challenge like you… need to check consistently and see whether its still up… very wierd that the network interfaces will just drop


Disconnecting for me seems to happen at a increasingly higher rate (some cases daily), when the network or pool has high fluctuations in MH/S.

Might just be a coincidence but something I’ve noticed.


With the network size I am running, I recently threw in a https://www.netgate.com/solutions/pfsense/sg-1000.html

it’s a raspberry pi with a router software on it. You end up with a pretty powerful little computer managing the network. So far it has been exceptionally reliable.

Here is a pretty damn good write up about the boost you will get if you figure out how to use one of these router devices. This is an option not to spend many hundreds of safex on a beefy router, it’s all in there…

I didn’t try this as mentioned I used that other device which works pretty much out of the box, and basically you put it between your switches with your machines and modem. So instead of using the lazy modem you can use the router as a heavy lifter for your internal network and let the modem just do that, be a modem.

We’re testing the latest sfxos currently, and I hope that it will be available within a month, let’s see how goes. Otherwise, I really appreciate the feedback, and it seems network stability is the biggest show stopper with this after all this time of using it.


I have been having the same issues with my Ryzen 9 build. I am currently trying a variety of things, and will let you know if I am successful in troubleshooting. Here are a couple of my observations as well as my log.

I saw on a Monero forum that some of the earlier xmrig releases had a memory leak, I tried running the most recent version of xmrig and got faster hash speeds but encountered the same drop from network.
I notice that my connection drops consistently after 151 accepted jobs, and I have never made it to 200 accepted jobs on my miner before dropping from the network.

When my rig drops, I get a message in my shell after a while that “packet_write_wait: Connection to 192.168.###.### port 22: Broken pipe”.

I have copied my var/log into a Pastebin and will post here for visibility if anyone can use this to help diagnose what is happening.

I’m trying to get a cheap graphics card to be able to look at the motherboard BIOS, as it looks like it may be an issue with over clocking.


My miner has disconnected no less than 5 times today. I mine in the pool, not sure i can give a log as it’s just Ryzen 9 and Ram on the mother board.

Think I’ll just buy a new router and see what happens.

1 Like