Pool hash rate significantly lower than local hash rate

I’ve upgraded my video card and got higher hash rate on my local machine, but the pool reports my hash rate to be 1/3 of what I am getting locally. I am getting around 900 H/s on my local machine and around 200 H/s in the pool. I have tried multiple pools. Please help!!!


Can you confirm what you mean by “higher hash rate on my local machine”? Are you running a pool locally? Or do you have the blockchain + stratum combo?

I kind of gave you an idea in the other thread, I am by no means an expert but that is what I am experiencing.

I understand what you mean now. Your miner is telling you one speed, and the pools are telling you another.

This is because the mining software doesnt communicate what your hash rate is to the pool. So the pool has to estimate what your hash rate is based on how many block solution submissions are you making, and averages it out.

I wouldn’t worry - you’re still getting the same performance. It’s just at the lower speeds, it’s harder for the pools to accurately work it out.

Most pools adjust your difficulty over a period of time, so i suspect the longer you leave it, the more accurate it will become.

Case in point - my personal miner is doing 2.5KH/s, but on the Safex News pool, it’s only showing up at 1.75KH/s.

You’re not losing performance. It’s just the pools have to guess your performance as best possible.


I also see that when I notice a drop in what the pool is showing, the latency to the server is higher so that may contribute as well to what is displayed.


Thanks everyone! I was only mining for a few hours when I notice the different rates. I will let it run longer. Thanks again!


After running for 2 hours, I was only able to mine .33 safex. The calculator says at 900H/s I should receive around 12 per day which is 1 every 2 hours. Is this normal?

1 Like

What pool are you in? And what port? Also the calculator isn’t accurate some pools I have noticed.

Currently I am in safex.xmining.pro, but I have tried eu.pool.safexnews.net and afex.cool-pool.net with same results. I tried both 3333 and 4444. Thanks again for your help!

I started in mining pro:4444 and had about the same results. I am in eu.pool:3333 and have had way better results. It really is all about the shares. I ran overnight and made about 10 SxC, another night same time frame I only got around 6. Why you wouldn’t be seeing better results in EU is weird. Maybe check your ping. if it is high you may not be getting as many shares to the server. Also what card do you use? If it is an AMD card with 18.xx drivers you have to roll back to 17.xx. Other than that I couldn’t begin to give another guess as to what the issue is. One ore thing when your miner is running hit R and see if there is any error messages, That’s how I found out about the AMD issue. I was running at 1-1.2 khs and the server was only getting the Hashes from mu CPU.

1 Like

It is probabilistic so its possible whole month you got 0 then all of a sudden win a few blocks in a day;

1 Like

You also have to factor in how many blocks a pool may find whilst your mining. Remember, you’re only rewarded if the pool finds blocks. As Dan said, sometimes it might be a case of a pool doesnt find a block for 4-5 hours then all of a sudden they find 10 blocks in a row.

Ping shouldnt be a huge problem for pool miners. We have pools in the US and Europe, and i know for sure we have Australian miners actively mining in both pool locations. Ping only gets to be an issue when you’re in highly competitive network hash rate levels like ETH and BTC.

As a final thought, keep in mind that it takes a depth of 60 blocks for any mined blocks to get unlocked and you be allocated your share of that block. This can take upwards of two hours to unlock. So after your two hours, then you’ll start to see shares allocated to you.

So keep mining for longer than two hours because it takes two hours for your first shares to even turn up. But also keep in mind that you’ll be receiving funds for two hours after you stop too as all those blocks you helped find get unlocked.


Im mining from Aus and not having a problem with ping on any of the pools I’ve tried unless i have issues with my ISP


Issue finally resolved! Thanks for all the help everyone. I was getting gpu errors when I pressed R, and this was causing all the gpu blocks to get dropped. I switched OS to Ubuntu and used the 17xx driver. I do not get anymore gpu errors, and the pool is showing similar hash rate to my computer. Thanks again!


With the 17.xx drivers you can use Win 10 if you wanted to. Mine runs perfect.