SFXOS: Safex Cash mining operating system support

hmm, the OS is still running. just that the mining process stops.

after i do a reboot, it runs perfectly… so was wondering is there any command that can make the process auto restart if it stops

1 Like

I let the developer team that contributed to this know about your feedback and also linked to this thread, so should be resourceful for us. Thank you for sharing your experiences

5 Likes

hey… my miner hanged… i did a reboot 2 times but the miner software didn’t auto start like it normally does.

when i run the miner software manually it works… any idea how to resolve it?

extra notes: i have 2 lappys running on the same network. only one giving this problem

Personally, I’d try reflashing the stick on the one that seems a little funky.

2 Likes

was planning to do that too, just seeing is there any technical thing i should check first :smiley:

all good, will refresh the stick and share

2 Likes

At @aussiesloth’s request, I am outlining an issue I had setting up a new miner.

At the end of May, I set up a Ryzen 9 rig following Dan’s instructions. The rig has worked like a charm 24/7. Whenever I’ve had to restart it for any reason, I’ve just turned it on and it goes.

About a week ago, I decided to set up another rig, so I bought the exact same parts that I used to set up rig1. I expected it to be easy to set up rig2 in light of my experience, and it was, but when I turned rig2 on, it wouldn’t mine. The fan would turn on but would never kick into high gear. Because I had another rig that was operating, I was able to rule out any sort of issues with the hardware. If I put the new parts on rig1, rig1 still worked but rig2 never did. All ethernet slots on my router also work fine.

I was at wit’s end, but I followed the advice of @sharan and purchased a graphics card. With his coaching, I was able to get into BIOS. The BIOS software on rig2 is a little newer than on rig1. I found that by manually going into BIOS and then exiting, SFXOS would launch. After I got rig2 to operate and mine, I turned it off to see if it would work properly when I turned it back on. It didn’t, so I had to go into BIOS again. The rig has been running fine for the last 5 days, but I suspect I’ll have to manually launch the program whenever there is a power outage, etc.

I use the ASUS Prime B450M-A motherboard. I suggest that when one of the developers has some time after TWM launches, he takes a look at this issue and assesses whether SFXOS should be updated so it can launch automatically.

3 Likes

do you mean you can enter the linux OS, just that the xmrig doesn’t launch?

1 Like

Xmrig doesn’t launch without intervention. With rig1, I just turn it on and it starts mining automatically - couldn’t be easier.

i got this same problem every now an then also.

i got a few cases:

  1. when running xmrig will shut and no auto start.
  2. even when reboot, xmrig does not auto start (i reflash by usb stick and it works after)

Hello, would like to take you up on phone conversation. Still having difficulty. can email me info to crim6920@protonmail.com. Thanks, Altoidfiend (chris)

Is there a way to mine using this setup with wifi?

1 Like

Found it in the other thread.

3 Likes

Thanks Dan!

1 Like

Postscript:

I suffered a power outage yesterday and had to turn my rigs back on. I expected to have to go back into BIOS for rig2, but was pleasantly surprised to see that rig2 started mining again simply by turning it back on with a screwdriver. Apparently the problem corrected itself, or I somehow corrected it when I was fumbling around in BIOS! :grinning:

5 Likes

Having the issue with Miner shut down and couldn’t reboot, reflashed drive loaded and back to original issue of same the browser isn’t updating the config file, had help from sssharanster and he had me SSH and do this Modification to config file Believe this was first step or could have been second Help needed pls. free -mh

Asus b450 pro4

sudo lsof -i:3311

cat /sfxrig/xmrig/config.json

sudo cat /root/backup_config.json

sudo cp /sfxrig/xmrig/config.json /root/backup_config.json

Cat command to display file contents
cp command to make a copy of a file
scp - secure copy

bash /sfxrig/sfxrig-local.sh

/sfxrig/xmrig/xmrig -c /sfxrig/xmrig/config.json
ps -ef | grep sfxrig

sudo service xmrig start

Or this was first and the above second
ps -ef | grep sfxrig

Second Command

/sfxrig/xmrig/xmrig -c /sfxrig/xmrig/config.json

Thanks in advance!!

2 Likes

did you change the original password?

1 Like

No didn’t see in the directions to do so.

1 Like

@Shakyamuni, i noticed that when it happens… the network seem to fail… i have a few laptops on that network… and it seem that only the pc that has problem unable to reach my router gateway.

all the other laptops are fine… so during reboot, it probably reset something on the network drivers…

any idea to fix it?

1 Like

All laptops work fine I needed manual input of wallet address in flash drive

1 Like

i tried to restart all the network interfaces… dont seem to work…

only a reboot will help it. if you have any idea to go around it… do share