twm 1.6.0 wallet Send Error

When I try to send any amount of SFX I am getting an error message that says I don’t have enough funds to cover the fee, even though the error message shows my total as being enough to cover the transaction and the fee combined. I’ve tried lowering the mixin but I still get the same error pop-up.
Screenshot (602)

You sure you’re on the latest TWM v1.6? I do recall seeing that issue with an older wallet ver.

Also, was the blockchain synced to top block?

Yes, I am on the latest TWM and it is fully synced. What’s strange is that the pop-up shows the correct total of the wallet and the total of the withdrawal with the fee, but it somehow can’t do the calculation right. I use this wallet for my mining rewards. Are there any better gui wallets for SFX other than this one. I might have to just use an exchange wallet. By the way, today I was able to send the SFX. I don’t trust the TWM wallet anymore. A month ago it forgot what my password was and wouldn’t open with the correct password. I had to use the seed to recreate the wallet.

Aside from the cli wallet, the TWM wallet is currently the only GUI wallet released.

It is never recommended to mine directly to an exchange deposit address, and depending on the way mining is being done, it may not be possible, as integrated addresses cannot directly receive block rewards from a node afaik, if you happen to be solo mining. If pool mining, check for any advisory notice on the pool website regarding mining to an exchange address.

For the password issue you had, I expect it was the result of a corrupted data file. This can happen under certain conditions (hasn’t happened to me yet, so only going on what I’ve been told) when you close the wallet and it was in the middle of some type of operation in the background. If you see a new file with .unportable extn appear with your wallet files, then this is the case. Normally you can simply delete the data file and the .unportable file and then it will open and you let it rebuild a new data file.

The alternative is indeed to simply restore from keys/seeds. In such cases, if you have previous marketplace purchases in the wallet, then you can grab a copy of your old .twm file, and it can be brought back over once the new wallet files are restored, making sure to have the name of the old .twm file the same as new walletname.

Further reading: An Explanation of Safex/TWM Wallet Files

Given the size of your tx fee (~22 SFX), I expect you have your mining payout set to the default/minimum. If you are getting multiple pool payouts per day, then I’d suggest increasing your payout amount, so you receive fewer larger payouts.

If you end up trying to buy goods on Safex Market from your mining address and you have left your payouts to the minimum, then you’ll likely strike this issue…

Just to let you know… I just had the same error get thrown on my mining wallet, as I went to move my mining rewards to my main wallet.

Error was thrown at mixin 3, but reducing it to mixin 1 saw it go successfully, but only left 0.02 SFX unused in the tx formation. My guess is that at mixin 3, I didn’t have enough spare outputs, above what I was sending, to cover the mixin requirements.

While the error message could be clearer, I don’t think it is any issue with the TWM wallet. It will simply be a limitation of outputs, as needed under the CryptoNote tx creation requirements.

Had I tried to send a smaller amount of my balance (with extra spare outputs for the higher mixin) I don’t think it would have been an issue.

Further understanding of outputs at Why my coin balances change after I made a transaction?