How to handle a Sails v7 migration bug i run into


I run into a Sails v7 bug with my attempt to migrate and look for some guidance.

I was fine with the step of “Setting the First Half” and also waited for it to confirm. Once the wallet showed the correct BTC balance (no more pending) I could also verify on that the first transaction was confirmed. I was then ready for “Setting the Second Half”.

I had 0.00009371 btc balance left which was a bit more than the 0.00007347 that Sails v7 stated was needed. (I have a picture of this taken with my phone so the bug is documented.) Since the wallet thought there were enough I was able to press the “Setting the Second Half”-button. But apparently there were not enough and therefore no transaction was conducted. There is no transaction recorded on and no pending one showing in the wallet or on However, the Sails v7 migration anyway moved on to the Final Step - Burning your Safe Exchange Coins.

Since the bc estimate bug prevented the second half I have not hit the burn button as I assume it will make the error worse. The question now is how I can handle this? I don’t find a way to go back and request “Setting the Second Half” again, so I’m sort of stuck in the middle.

Any suggestions and tips on how to handle the situation would be greatly accepted.

Thanks in advance!

You need more BTC on your address to cover the txn costs, as it refuses to use dust (lots of very small BTC pieces).

I would recommend you send 100k sats to the address, then hit the Reset button in the Migration window and start again.

After you are done with migration, you can remove any remaining BTC.

Hi! I added bc and hit the Reset button. I was able to complete Part 1 and Part 2 this time. (Wallet still showing a less amount of bc needed, but this time I had more on the wallet so it worked out.) I waited for confirmation on Part 1 before proceeding with Part 2. Then waited for confirmation on Part 2 before doing the final step of Burning. After selectning burning I got the confirmation window and went on. However, upon checking at the bc blockchian, there were no transaction for the burning part. I let it be over the night and checked in the morning. Still nothing to I redid the burningen in the Sails v7 wallet. This time I did get a transaction that I can see on the bc blockchain. However …

What is now a problem is that nothing shows up in the Migration Table of the Sails wallet. According to the video it could take some time like 45 minutes or so, but I’m not up 40 hours and still nothing shows in the table.

How do I know if my migration worked fine or not …?

Thanks in advance!

The script that populates the Migration Table has an issue, and hasn’t been working for a week or two. If you used the BTC and Omni block explorers to confirm your transactions worked for Set - Set - Burn, then you should be confident that you have done if correctly.

Once Dan next runs his Migration Script (currently scheduled for 30 October), your SFT and SFX should migrate to your new address, which can be viewed with the v2 Orbiter wallet.