New Wallet no coins showing up HELP!! before migration

Hi All,

I have downloaded the new Sails V8 wallet and logged in, but can’t see any of my coins to do the migration, I have around 1 million coins and desperately need help to find out where they are.

I had an old wallet on my old laptop that died which was from late 2017.

Here are my details:

My Safex Address: 1HUDnWUBn3j24z4TgjFmpuRYwGsBHck9XM

My Public Key: 13Uj6Drsmyinqfd8jwJWMEcNaL2eiBGFNr

I have also downloaded the Orbiter wallet but to recover a wallet it’s asking for spend key and secret spend key which I only have a secret key so not sure what to do there and if they will recover an old wallet with my keys in it.

I appreciate if someone could advise how I can retrieve these coins from an old as they just aren’t showing up and I’m not sure what I can do to retrieve them ?

Please help.


Forget about the Orbiter wallet - that is for after migration.

As to your coins…

You need to import your address 1HUDnWUBn3j24z4TgjFmpuRYwGsBHck9XM into the v8 wallet, if it isn’t already there.

You need your Private Key (never share it) not your public key, and then use the IMPORT function in the main wallet section (not the migration section).

Below is what I now have in V8, however the coins are still not showing up, does it take time for them to come across from an old wallet.

I’m in the home section not in the migration section.

I’ve imported my address 1HUDnWUBn3j24z4TgjFmpuRYwGsBHck9XM into the V8 wallet, not sure what I then need to do to get the coins to show up ?

Please help.

You have simply labelled a different wallet address with 1HUDnWUBn3j24z4TgjFmpuRYwGsBHck9XM

That is not importing an address.

Watch the importing section of

The problem is I don’t have a back up of the wallet so that won’t work and tried the move to archive and back to home again and that didn’t work either.

I’m really not sure what else I can do to retrieve my previous wallet with all the coins into this latest version.

Is there anything else I can try ?

Really appreciate your help.


I think that field may be at the bottom of the window in the current wallet, but that is where you paste your private key, then click import.

That’s the thing I have imported my private key, when you press show private it comes up so looks like its come across just my coins aren’t showing up.

When I import the private key should the coins show up then or do I need to do something else after that for them to show up ?

Do you have a record of your address and keys from when you had the wallet setup in 2017?

Pushing Show Private key will show the key for the addresses already loaded. It won’t magically show you the private key for an address you haven’t yet imported.

Every address has its own private key (or keys) and you need to keep records of such things safe and secure, in case your PC dies, etc.

You cannot install v8, create a couple of addresses, look at their private keys and expect to magically have it import your address with the wrong key.

Yes I have my old Safex Address, my old private key and my old public key.

The screen shot above number starting with 13U is my old public key. when I press show private key it’s my old private key.

So not sure what I do now given it’s all my old keys and address from 2017 ?

I can also see them on the Omni chain explorer, so I know they are there I just can’t get to them, could someone please help as I’m clearly doing something wrong and I don’t won’t to loose $1 million coins.

Are you referring to this one? Please tell me you DO NOT mean this one.

Right now it’s showing up as this this and these are my details:

Any advice as to what I should do now ?

My Safex Address: 1HUDnWUBn3j24z4TgjFmpuRYwGsBHck9XM
My Public Key: 13Uj6Drsmyinqfd8jwJWMEcNaL2eiBGFNr

See down the bottom of that pic… the IMPORT section.

You need to enter the private key for 1HUDnWUBn3j24z4TgjFmpuRYwGsBHck9XM

You will not find that private key inside the wallet.

You should have it printed out on a piece of paper or as a file on a USB stick, etc. as a backup.

THAT is what you need to do.

@brettfau77 fwiw… the 13Uj… address you are referring to as your “Public Key” is a completely separate wallet address. It has no relationship to the 1HUD… address.

Sorry to reply here (not in my topic) but I have the same problem. My coins are seen in the history when I’m in 0.0.6 version, but there is no any history at all if I switch to 0.0.8. Please help

Screen pics please.