NOTICE - Fix for the OSX blue screen issues

Update - We’ve updated the binaries for OSX which should now solve the blue screen issue. Please download the latest files here:

A number of MacOS users are experiencing blue screen issues when running the new Safex Wallet v1.0.0.

What’s happening?
It seems that certain x-code compiler versions aren’t including the openssl library in with the installer. We found this to be the case for the dedicated Mac compiler machine we have for the official releases (the ones with the Apple certification).

The issue here is that there doesn’t seem to be any fixed pattern for working out which users will be affected or not. Essentially, if you’ve got any other software installed that uses openssl, then most likely the wallet works for you.

What we’re going to do
We’ve identified the cause and will get an updated version out as soon as possible. As this is the Easter holiday weekend in Serbia, it will most likely be from next Tuesday onwards.

Possible solution
It may be possible for you to install the missing library required which is causing the blue screen. For this you’ll need to open up your terminal.

Note - standard warning applies. Please perform these actions at your own risk. If you’re unsure of anything, please wait until the official fix has been released.

Step 1 - Install Homebrew
Homebrew is a package manager that is used for downloading and installing missing packages, just like our openssl. You can visit homebrew’s website here:

In a new terminal window, paste the following command and hit enter.

/usr/bin/ruby -e "$(curl -fsSL"

Before running, it will tell you what it is going to do. If you’re happy with that, hit enter and let it continue installing.

Once installed, close your terminal.

Step 2 - Install OpenSSL package
Next we need to install the OpenSSL package. Now that we have homebrew installed, this is pretty simple.

Paste the following command into a new terminal window and press enter:

brew install openssl

Once installed, close the terminal. It might also be worth restarting your Mac just to be safe.

This solution should fix most of the blue screen issues. There may be some further variables that have not been exposed yet, like running on older versions of OSX, or softwares that may be conflicting with the wallet installation. We won’t know until you test this potential fix.

Either way, the developers will address this as priority upon their return next week.

I’d like to thank everyone for their feedback so far. Releasing software is never easy. We have have a very thorough internal testing procedure, but nothing prepares you for the hundreds, if not thousands of different OS and hardware setups faced with the general public.

1 Like

It seems the same problem is present on ubuntu 16.04 (up to date systems), I have a blue screen when i start the wallet and nothing appears.
Thank you for your help

Hi Mike. Our Ubuntu binary is built for Ubuntu 18.04.

If you need a wallet for Ubuntu 16.04 you’ll need to self-compile. Instructions can be found on the repository.

I’ll speak to the devs to see if they can produce a 16.04 build. However, our standard support is for 18.04.

I’ve got version 2.0.0 dated July 19 but I still get the blue screen issue. I haven’t done the homebrew fix as I didn’t want to mess up my Mac. Do I need homebrew since v2.0.0? Is there anything else I can do? For your info:

Operating System:
MacOS Mojave 10.14.6

Blue screen when performing “Recover Wallet With Keys” in Orbiter Wallet v2.0.0

Steps to reproduce:
I key in the three required keys and a password. I click on “RECOVER” and enter the wallet name, click [SAVE] and then the screen is blank and blue. I checked the safex processes with the Mac Activity Monitor and they’re not using any CPU time, the Disk IO is not increasing and there is zero Network activity. In addition not wallet files have been created.

Expected result:
A message window with “Please wait while your wallet file is being created.”

Reproduces how often?:
Consistently, every time

Other Info:
I tried the following but they made no difference:

  1. I tried omitting spaces from the filename;
  2. I tried using a small, letters only, password.

Initially, I tried the “Create New Wallet” option and I also got a blue screen after keying in a wallet name.


1 Like

There have been issues with Orbiter on some Mac OSX versions.

For right now, you can use the cli wallet.

However, the new GUI TWMwallet is only days away, and it has been working on most Mac for the stagenet version, so is very likely to be fully functional for those Mac OSs with the Mainnet release.

1 Like

Fantastic, thanks. I’ll wait for the new wallet.