Problem with migration

today i tried to migrate my old safex coins and when i press migrate it shows me a message that says : Either you do not have enough bitcoins to complete the transaction or the connection to the bitcoin blockchain is interrupted . i have like 1.24$ bitcoin in my adress . is the system off or i cant migrate my coins anymore cause the time of migration end?

So this issue is normally caused by one of two things:

  1. The BTC you have in your wallet is made up from lots of smaller BTC transactions. This is normally called dust. If this is the case, i’d recomend sending a single transaction of $1-2 to that address and try again.
  2. If it’s not related to BTC dust then for whatever reason your wallet is struggling to connect to the BTC server to determine the appropriate transaction fee. This is done so that you’re paying the right sized fee so as it’s not getting lost in the BTC mempool.
    A good way to determine if you’re connected or not is to check the lower-left corner of the wallet and see what the status is. If it’s green, then you’re good to do and it’s most likely issue 1).
    If the status is red then most likely your connection is having problems connecting to the BTC server.

  • Certain Internet providers block access to non-standard ports. It might be that your ISP is simply blocking communication to the port that we use for the BTC fee checker.
  • Certain countries (Russia specifically) have blocked access to EVERY Digital Ocean server in the world (they wanted to bury Telegram, which is also hosted via DO).
  • If you’re trying to connect to the wallet via workplace connection - again they might be blocking access to non-standard ports or whitelisted domains.

A good way to check this is by loading the wallet whilst connected to the internet via a VPN. I can’t recomend one specifically but there are a few free ones you could try to confirm this theory.

I can confirm the BTC server is running OK as you can see in the image above so it looks like the issue is isolated to your local area.

Let me know how you get on.


i solve the error by sending new bitcoin to my adress but now i get another error after i press “set the first half”:error getting UTXOs Error: Transaction has no inputs. but my bitcoin is pending so i guess if i wait then the first half will be seted . .

the process was so fast when i press set the second half i restart my wallet and my pending btc was already 0 and for burning my safex says Final Step - Burning your Safe Exchange Coins

You will need 0.00137388 btc this is quite alot from other videos that i see it asks for less

it already take me about 4 euro worth of bitcoin to proceed to the steps

There are varrying factors in the cost per stage. It’s dictated by the average fee per BTC transaction (as the Omni Protocol is a layer ontop of the BTC blockchain). Recently, prices have gone up.

However, at the beginning the instructions do say to take your time and don’t rush it until each stage is properly confirmed. If you click things too early or try to force the next stages before it’s had chance to confirm, you are going to be faced with issues. You can only perform one transaction at a time.


Hello Richard,

I am having the same problem. I am trying to migrate my safex to the new blockchain but I am getting the “Either you do not have enough bitcoins to complete the transaction or the connection to the bitcoin blockchain is interrupted”
I have 0.000508 BTC in my wallet but it does not allow me to migrate. I tried sending a fresh BTC too but it still does not work.

The bottom left part of my wallet says Synchronized and both Safex and BTC have green circle next to them. I also tried by using VPN but it still did not work.

Please advise.

Thank you!

@Rich.bate - Can I please get a response on this? I am still having trouble. Thank you!

I can’t believe I just paid around $30 to perform the migration. This is outrageous. Ooooof
The cost to do the final step was 0.00132248 btc. Ooooooof

A perfect example why moving to the new Blockchain is so important… no control over fees when piggybacking on another Blockchain.

The total migration costs when first able to do it last year only totalled 12-15k sats for the 3 txns combined, but the current bull run and massive increase in BTC transactions has resulted in the fees going crazy… that is the BTC network, not the fault of Safex.

Had you done the Migration earlier, you’d have only paid a dollar or two.


Does some script need to run for my safex to show up in the new wallet? I performed the migration 3 days ago but it has not showed up in my wallet yet.

Yes… you’ve done the burn, now you wait for Dan to run the Migration Script… next scheduled running of it is 10 June.

i am at the position as shown in the pictures. I proceeded with migration only in December '19. any chance i get my coins?

You need to install Orbiter v2 wallet and import your keys. What you have is v0.0.8 Sails migration wallet which has no access to migrated tokens that are on new blockchain now. You can find Orbiter wallet on in download section.

I do have it but no coins send there after migration since 30/12/19.
any options?

Thanks in advance

You migrated on 30/12/2019? Well, sorry to inform you but migration window ended on 30/11/2019. You were a month late. I am afraid there is nothing you can do if so.

1 Like

Am i the only one not informed on time about the deadline? Just wondering…
Anyway thank you for your time.

From 2017 and the chilecoin chat, there was always going to be a move to a new currency.

From the blue paper release in January 2018, there was a clear path to the SFT/SFX Mainnet.

From mid 2018, the sft/sfx testnet was in the works, and by September 2018, the Mainnet was launched and the migration process was getting developed.

From early November 2018, until end of November 2019, the migration window was open for people to complete the migration process… a 390-day window.

A further 48 hrs was provided at the start of December 2019 as a grace period, just in case someone rushed the process in the final hours of the migration window and made a mistake.

All of the above was publicly available. The project team broadcast the migration information regularly on social media platforms and on the project forum, website etc.

The information was readily available to everyone following the project.

No, you are not the only one who missed all of the above.

1 Like