Problems with TWM wallet & missing tokens

Installed TWM wallet and selected “Recover Wallet From Keys”, recovered my old v7 wallet address (That I migrated SFT & SFX to) using private spend and view keys, Set up and noted down new password…No sign of either my migrated SFT or SFX. Signed out and tried to sign back in again using “Open Existing Wallet”, selected the .keys file path as instructed…Get the message “Looks Like You Made a Mistake. Please Try Again” tried several times with no success. Started again and selected “Recover Wallet From Keys” and made sure I entered and noted the password…Still none of my SFT or SFX from migration are showing, logged out and then couldn’t log back in again with “Open Existing Wallet” using the password I set up again. Anyone else had a similar problem or know WFT is going on.

Thanks in advance

If you’d take the time to read some of the information already shared here on the forum, you’d have your answer.

Looks like I’ll have to wait until the bug is fixed to be able to sign in without messing about and restoring every time from your copied post below aussiesloth. I’m back in and after pressing “Hard Rescan” and waiting for a while the tokens have appeared.


Reported issue: password error when you try to open a wallet previously restored from keys.

Workaround: this seems to be an intermittent issue. For now is best to restore from mnemonic seed. If you don’t have your seed, then restore from keys (in Orbiter or cli) and immediately take note of your seed and backup the info. Then, if you strike the issue the next time you open the wallet, you can at least restore from seed and avoid a repeat of the issue.

If you don’t have your mnemonic seed and can’t use Orbiter or cli wallets to get it, then you’ll have to restore from keys each time you want to use the twmwallet, until the bug gets fixed.

1 Like

I came across @Cockney 's post looking for the correct way to initialize TWN for the first time, migrating the existing tokens.

For anyone like me ending up here:

AussieSloths’ link above isn’t the most informative, the most precise I found, and working way is here, written by AussieSloth (that’s also the correct thread to follow/error-report to help TWM evolution:

1 Like

PS: it worked for me, following (EVERY STEP DESCRIBED)

Syncing only took 12min or so and all “funds” showed up