Tokens and history aren't showing in my wallet [Resolved]

Good morning all, I have a problem, last year I downloaded the safex TWM 1 wallet and staked my safex on that wallet, after doing nothing for a year or so I opened the wallet again yesterday using my keys, although it was problematic when i got to the password stage and took several attempts, once the wallet was opened there was zero balance, today I downloaded the newer version 1.5 and did the same, this time it was easier to set up the wallet but there is still a zero balance, zero staked and no history, I have clicked on hard rescan several times, I also checked my address on the block explorer and nothing comes up, no history, there is also no history of transactions in the wallet either, zero staked and zero safex cash any ideas? thanks…

1 Like

Based on previous experience, I’m gonna guess you’re just being impatient. Connecting via the default Daemon host means a likely slow block sync, and you probably just didn’t wait long enough before you started pressing Hard Rescan. And then if you kept hitting Hard Rescan, you were just restarting the process repeatedly and never letting it finish. Who knows what state your wallet sync is currently.

Have a read of Selecting Another Daemon Host for Faster TWM Wallet Access

Open your v1.5 wallet and connect using a close node.

Immediately hit Hard Rescan, and then just leave it alone. Be patient. The balances will appear. Don’t expect them to appear as soon as the block sync shows top block. It can still be some minutes later before they update.

Thanks for getting back to me, I left it overnight but will do exactly as you say and get back to you tomorrow, cheers

1 Like

Hi there aussisloth,

I did as instructed using a node from Amsterdam as I’m in the UK, hit rescan and left it running all night and had the same result as above, I am also running a Theta node and thought that might be making some sort of disruption so closed that too. I also tried opening the wallet using the seed phrase to see if that would make any difference and at the last step got the message below…

’Electrum style word list failed’ and when I tried to close the wallet it says 'closing wallet (Test)'

I’m an old boomer that got into cryptos for political reasons so please forgive my giving any info that is probably totally irrelevant, cheers

1 Like

A couple of things to check…

  • the wallet address you’ve been restoring is the same address you had coins on. You didn’t create several wallets??
  • Safex seed phrase has 25 words. They need to be entered into the field together, with a single space between each word, no spaces before or after.
  • does the wallet say it is Connected to Safex Blockchain up near the block height? (If your ISP or firewall is blocking ports, you may not be connecting.)

Screenshots of issues/errors are always helpful.

Yes, I moved my tokens to the twm 1 version a while back when the safex cash was released as a reward for hodlers, then staked my safex tokens, closed the wallet, then opened it again to make sure everything was in order and that was that, this is thesecond time I’ve tried re-opening it. I only ever had the one set of keys and one wallet address which obviously work to open the wallet. The seed phrase doesn’t work. The wallet is connected. enclosed screenshots.cheers


  1. showing empty wallet
  2. showing empty wallet history
  3. showing file containing new keys
  4. trying using the seed phrase
  5. showing file but seed phrase path not visible as it is in 3 when I used keys and address?
  6. wallet connected

Neither of these screenshots show the wallet has actually completed syncing with the blockchain…

It will just display the top block, by itself, when it has finished syncing, and even then, the balances can still be some minutes later before appearing.

But at least we can be confident you’re connecting with the blockchain now.

You can also click on the key (green highlight) to shows your address, keys and seed (obviously DO NOT share that here)

But that will allow you to compare the mnemonic seed phrase you have written down, with the one for the wallet address you have opened.

If they’re the same, then we can also be confident that you have stayed with the same Wallet address you think you have been using the whole time. If the words are different, then that will also be important to know, as it would mean the wallet address is different to the one you previously recorded, or you maybe wrote the words down incorrectly previously.

Your right, I just checked and the seed phrase is totally different to the one I have, I’m really confused now
as I only remember opening the one wallet, it also looks like I wrote down the seed phrase wrong or I would be able to use that to access the right wallet I suppose?

Correct on both counts.

Did you ever have the Orbiter wallet installed, as that is Safex blockchain as well?

Yes, I’ve just been checking through my passwords etc and it’s the old orbiter seed phrase I’ve been trying to use, dumbass that I am, I still can’t figure out why I have keys that work but are obviously not tied to my account, I’ve found some other keys and I think I’ve found the right one, just rescanning it now, I’ll let you know either way, whatever happens thanks a lot, I really appreciate your help

1 Like

The seed and keys from the address you used in Orbiter wallet can most certainly be restored into the TWM wallet, but if you created a new address with TWM instead of just restoring the old, then that explains everything.

Good luck and let us know how it goes. :crossed_fingers:

Yeah sorted, thanks a lot, luckily I kept all my keys, I had the right seed words but wrote them down in the wrong order, can’t take the weed at my age! one more question, do we have to keep the wallet open if we’re staking? I know that’s the norm with some other coins I have.

1 Like

You’re thinking proof of stake.

Staking for SFT is completely different, as rev share returns are determined by Marketplace purchases.

So you can stake and close the wallet, no problem at all.

I noticed I’d accrued a small payment, although it’s not dropped into my wallet yet, anyway, thanks very much for all your help, I wouldn’t have worked through my cock up without your prompts, much appreciated, cheers.

1 Like

It won’t drop into your wallet balance until you unstake… How to Unstake Safex Tokens?

I would recommend educating yourself about Safex by reading through the various sections of the Knowledge Base

Yes, that’s probably a good idea lol, thanks again

1 Like