Proving Coindeal transaction

Hey guys.

Trying to prove a transaction I sent for 10 SFX from Coindeal.

I have the TXID, just not sure where the actual transaction is? How do I get the TX private key under the ‘Prove Sending’ tab in the explorer?


You can’t Prove Sending for a withdrawal from CD, because you don’t control the Keys for that wallet that made the tx, so can’t access the private tx key.

You can only Prove Sending if you did the Send. You didn’t - Coindeal did.

How about when I did tx from safexcashwallet? How to obtain tx private key? I see no option in wallet app.
I also tried using newest safexd daemon and imported keys into cli wallet. When I try to gey key:
get_tx_key 2577…
I get
Error: no tx keys found for this txid

Orbiter is just a simple send wallet. The tx private key for an orbiter tx will be in the wallet data, but accessing it isn’t possible with Orbiter, tmk.

Rather than importing your seed/keys into cli (the created tx send history won’t be in the new data file created, afaik) try opening your actual orbiter wallet files in cli. That way you should have access to the created tx data, and you have the full functions of the cli wallet at your disposal.

Actually, upon further thinking…

V7 cli wallet can only access data files that have been rebuilt since the hardfork, as per Updating CLI/RPC wallet to be v7 Compatible

So depending on Orbiter files, may not be compatible.

Also… get_tx_proof is something you could look at.

When I import the wallet file cli crashes.
How to extract tx private key from tx proof?

Like I said in the prior comment above, starting with “Actually…”,

I’m not sure that subsequent to the v7 hardfork that you can load the orbiter wallet into the current cli, due to the incompatible nature of the two data formats, with the implementation of the advanced transactions of the marketplace functionality.

From the v7 hardfork block to the present, you should be able to use the current cli wallet to make txs and also then access the proofs etc.

You keep responding to questions I didn’t ask.
My question is still standing. How do I get tx private key?

Use get_tx_key txid

Then you plug in the key and recipients address in the explorer for the prove.

As I wrote few posts above.
I already tried that and I get:
Error: no tx keys found for this txid
Despite the fact that I can see that transaction in history.

As I explained above, you needed to have sent the tx from that wallet file for the tx key to be in the wallet data file.

You said you restored the wallet from seed/keys, therefore that wallet file didn’t create the tx.

The project has just undergone a major code transformation with the v7 hardfork. There are some minor downsides to that, such as not being able to open wallet files created in v6 wallet versions.

It will work for any tx after the v7 hardfork IF you use the wallet that created the tx.

So using latest wallet it is impossible to obtain tx private key of my own transaction from earlier wallet version? There are no import converters capable of importing this critical data?

If I run V6 cli wallet will I be able to import safexcashwallet and read txid? Or it is gone forever?

I’m no expert, just a community member who tries to help with support. Sounds like you have the technical capacity to figure that out for yourself. So feel free to check it out.

1 Like

You can always use private key / mnemonic seed to log into client wallet even if file format has changed. On client wallet you can see transaction private key.

There are some videos explaining client wallet out there if you don’t know it yet.

I suppose next wallet will support old file format again and even if not you can get private key from orbiter and import into new client wallet which will release soon.

That is only if that specific wallet file was used to create the tx. If you restore the wallet from seed/keys, the wallet data will no longer contain the tx private key tmk.

The issue for accessing old (pre v7 hardfork) tx private keys is…

the pre v7 hardfork wallet data format is no longer compatible with the v7 wallet, because of the addition of the advanced tx functions associated with marketplace.

So, for example, a cli data file… you have to delete/rename it (but not the .keys file), then open the wallet and it rebuilds the data file in the v7 data format. But I don’t think the old tx private keys would still be there after the rebuild.

I still have safexcashwallet installed and i can still open it. However in transaction history I cannot find tx private key.

Chiming I’m here, still need to read the thread more closely yet please for naming and confusion sake

Please refer it to the txkey

Not transaction private key. Suddenly you might end up suggesting people to send their private keys. Please focus on this detail in the communication.

I will chdck the thread this evening but this came to mind immediately to mention to protect us and anyone reading for the future.

Txkey proving the transaction. Not private key.

1 Like

Thanks for interest. Long story short. I did send SFT using safexcashwallet. Now I want to get txkey for it. Wallet app does not show txkey. What to do?

1 Like