Windows TWM: Reporting issues

Please post any issues here. Any resolutions to reported issues will be posted in Windows TWM Wallet: Getting it going to ensure a single source of information for all matters relating to the Windows wallet.

11 Likes

3 minor issues:

1. password error
I selected ‘recover wallet from keys’. Created a password. Next time I tried to log in with this existing wallet, it keeps saying that my password was wrong. Which wasn’t. This problem did not appear when I recovered my wallet using seeds phrase.

2. could not type in amount of tokens to stake
I couldn’t type in the section ‘how much to stake?’. I could paste something.

3. could not type in 'show keys’
First attempts I wasn’t able to type in the password section after I clicked on ‘show keys’

2 Likes
2 Likes
1 Like

Wallet does not seem to sync. Stuck on 246998 / 666699.

i cannot stacke tokens with errors !
you’r network fee for staking is 0 sfx ! and token staking transaction successfully submitted ! but after that 0 token staked !!! i have 100k sft and 0 sfx.

Every tx requires SFX to cover the tx fee. Even SFT staking or transfers. You need SFX in your wallet.

4 Likes

Do a Hard Rescan and leave it an hour.

After I staked 25k, the wallet shows me a completely wrong amount of my total SFT. It’s neither the original amount nor the original amount minus the staked amount. Its just a random number which isn’t in any realation to my total amount of sft or the amount that I staked. Any idea?

Ah and the SFX amount was wrong, too. But I did a hard rescan, waited a couple of minutes and restarted the wallet. Now the correct balances are displayed again

For the benefit of everyone who will be staking tokens for the first time…

Safex uses the cryptonote system of outputs
When coins get moved, think of it like paper notes in your fiat wallet. If you receive your SFT in a single 100k tx, then you will have one 100k SFT note in your wallet.

When you stake your SFT, even if you only stake 30k, the smallest note you have is the 100k output.

So your entire 100k stack goes into the tx that gets sent to the blockchain for processing.

If you check your balance after you send the tx, but before it gets processed, your SFT will show a zero balance. That is normal. That is because you just handed over your 100k SFT note to the cashier (the blockchain) and you are now waiting for the tx to get processed, and for you to get your change back from “the cashier”.

Once the 30k SFT tx processes, a 70k output will be returned to your wallet, and 30k will appear in the staked balance.

Same for SFX outputs to cover the tx fee.

This is how it should work, so please, nobody freak out that their money is momentarily ‘gone’ :pray:

9 Likes

Thanks for the explanation!

2 Likes

I restored from keys and was able to stake SFT. When I closed the wallet and reopened the wallet the app didn’t accept the password.
Restored from keys again to a new wallet and tried to get the seed from the ‘show keys’ option but it asks for the password and gives error ‘Wrong password’.

1 Like

Thanks for the info. This seems to be an intermittent issue, as I’ve also had a report of it working properly via keys restore. But many more reports the same as yours.

How to start selling on the market place?
Thanks

Terms, some Resolution size issue with, cant see thick box. Answer to this is resize your screen,

A vendor onboarding and vetting process for TWM inc will be announced by Dan in due course.

5 Likes

Unable to unstake image

I just restored my wallet aswell and after reload it does still show 0 SFX and 0 SFT
But the transaction history is complete maybe just an update for balance-lable missing?

Do you have some SFX for the tx fee?
Did you try with at least 25k+ SFT, which is the minimum?

1 Like