Mac TWM: Reporting issues

Hi, I am trying the TWM dmg for Mac

I restored the wallet from keys

The wallet shows

Screen Shot 2021-03-29 at 9.02.10 PM

Doesn’t show my sft nor sfx. Do I have to wait? I don’t see any indication of loading.

If I sign out and try to open the wallet from Existing Wallet and I choose the wallet just created, when I enter the password, it says I made a mistake

I am using a Password Manager (One Password) and I am copying / pasting it from there. So I am pretty sure it is the right password. Unless the password box does not support well copy/paste.

Will keep trying

I just tried typing a simple password (Test1234) and still cannot open the wallet

Two transactions showed up if I go to the gear. I believe the first ones. So maybe it is syncing?

All transactions loaded. So that part of this report doesn’t apply. Still have a problem from recovering a wallet with a password

@SenhorCastor it seems there’s an issue with the password saving when restored from keys. If you have mnemonic seed, then use that.

Yes, it will be syncing in the background but there’s no visuals on the main pages, but you can see tx history populate in the :gear:

1 Like

@aussiesloth here’s to hoping you have a lot of coffee and patience these next few days.

I am having the same blue screen issues as the prior wallets with my mac.

Steps: restore from seed, enter file location, enter password, click on ‘restore wallet’. It then goes to this screen:

my mac is pretty old, so not sure if it’s worth anyone’s time to look into this, but figured i’d mention it.

Macbook. OS X El Capitan; version 10.11.6, bought in 2008. 2.4 Ghz, 2 GB memory (1067 mhz ddr3). 100 GB of free disk space. Not sure what any of that means, other than that I bought this 13 years ago and it’s probably time to upgrade!


That OS ver may be just a tad outdated there, @ihsoyiKiyoshi my friend :sweat_smile:

1 Like

I have the same issue as well, did a hard rescan and still doesn’t work, SFT no longer appearing.

I try to use the Orbiter Wallet to recover, SFT and SFX still loading…

I bet you didn’t leave it long enough after you hit the rescan button. Leave it an hour.

I do have the same blue screen issue that @ihsoyiKiyoshi reported in a mac OS High Sierra, so I believe it s not just a question of old system.

Computer specs if it helps-

MacOS High Sierra Version 10.13.3
Macbook Pro (13inch, 2016)
2Ghz intel core i5
8gb 1867 Mhz LPDDR3

1 Like

Yeah I’m having the password problem too when trying to restore with keys.

If I try to restore from mnemonic seed it’s telling me that I have only entered 23/25 words. I’ve counted and I’m definitely copying 25 words?

1 Like

Ensure there’s no line breaks. Have all word separated by a single space on one line (line wrapping okay,obviously)

1 Like

my bad, thanks!

1 Like

also had this issue when copying seed from terminal. Delete the spaces between the words and add them again. You can see from the format where the “faulty spaces” are.



I tried recovering from a seed phrase (not a file) and my balances did not show. I also rescanned the blockchain. Afterwards I tried closing the wallet and tried reopening the file that was created with the seed phrase. It said no file existed (but the file was indeed in the folder I created).

I tried @cryptooli advice and removed the spaces from the seed words but it said only 1/25 words were entered. Also tried making sure all the unspaced words were on one line.

He said remove the spaces and then add them back in again


exactly. after copy-pasting the seed phrase into the TWM field, you need to delete the spaces and add the spaces back again. then, you have 25 words in the correct format.



Thank you @znffal @cryptooli I deleted the spaces, then added them back. I had to reopen the wallet and do a hard rescan but all my coins are displayed.


Hi all, first time posting so please forgive if my image links don’t load

So when TWM released for Windows, I side loaded Windows 10 on my Macbook staked 100k SFT and left it.

Now the Mac version is out I’ve staked some more but can’t see my original 100k stake in the transaction field, it just shows as a stake but with blank output:

Hope this can help sort the issue for anyone else going forward.

1 Like

What does it show it the Token tab? In the Stakes table?

Bearing in mind, that top one hasn’t even been processed when you took that screenshot (block height 0 means still in the pool)

So msybe you’re just impatient. Let the other tx get processed and compare the two.